Error in training a new journey

I am not able to click on the training button for the new journey.

1 Like

Can you please confirm if you’re using platform?

no i am not using platform

1 Like

Alright, can you please try adding 5-10 utterances under User Expression tab? These are the phrases users will say to invoke this journey.
For example, in order to invoke the menu journey users might say Show me the menu or Menu please.

ya, i have added the user utterances but the training button stuck i am not able to use that for training the user utterances.

1 Like

In that case, you can restart the container.
Go to the Intelligence tab then from the top bar select Monitor. Under Bot Status you can click on Restart Container.

Hope this helps! Please don’t hesitate to reach out to me in case you get stuck again.

Happy bot building! :robot:

Training keeps on loading. So, I’m getting responses of utterances of deleted journeys. Even though I restart the container, the training button loading. How to solve the issue?

1 Like

Can you please share the bot access with me at We will inspect your bot and get back to you ASAP.

P.S.: I’ve reviewed your bot and fixed the training issue. Check your inbox for a detailed explanation about this issue.

Hi, the bot is working fine, I have created a journey called room, in that there are three steps start, types and response. sometimes all the three steps are executing properly but in sometimes the response part is not working, after the second step it is going to some other journey.
What is the problem?

1 Like

It seems like a different journey is getting triggered when you give input. To tackle that, you can use Exclude Params for Switching. To enable it; go to the right top corner where you can find Tools under that select Behaviour tab and enter the step name which you want to exclude. In your bot, it’s the types step since in that step only a different journey is getting triggered.

I hope this helps, please don’t hesitate to reply on this thread in case it doesn’t work or you have any other query.

Happy bot building! :robot:

Thanks that worked. I have a journey called user in that also i am facing same error i fixed it with your solution but after i added in the exclude params for switching the name validator is not working.

1 Like

Can you please share a screenshot? I tried your bot and user journey is working fine for me.


See now it is not validating my name but its validating email and mobile also.

1 Like

It seems like there’s an issue with Name validator. I’ll inform our team about this.
Meanwhile, you can use this regex to validate name step: ^[A-Za-z]+$

okay, thank you, then i am not able to trigger a journey. here i attached that coding.

return new Promise(resolve => { app.triggerIntent(‘room’)} );

please give some solutions please.

1 Like

Here you go: return app.triggerIntent('room')

Alternatively, you can also use the Trigger Journey in the response section.

if i click on the home icon, the bot should restart right? but nothing is happening.

1 Like

You need to add step to invoke room journey under the How to ask for Default ? section of the Default journey.

Hi my bot again stuck in the training loop. could you help please and can you tell me why this is happening again and again?

1 Like


Since you’re provided very little training data; I’d recommend disabling these 2 options.

Also, many of the utterances you’ve provided are very similar. You can try adding I want to book a room utterance rather than just room or rooms.