Facing issues with image and video message

Hi,
Adding a video or image type message is not showing anything on the bot and it skips to next step.
Fetching from a url is not giving anything and also it’s not allowing to upload a image or video(It keeps showing loading for long when try to upload).
When a video is fetched from a url ,it just shows a blank player. Please refer the screenshots.
And can you please say what image and video formats are supported in image and video messages .


2

Links used for fetching
Image Link : https://upload.wikimedia.org/wikipedia/en/9/95/Test_image.jpg
Video Link : Adding A Welcome Message - YouTube

Please let me know how to resolve these issues.
Thanks.

1 Like

Hey @Rajasekar, you need to upload media (video / picture) to display it in the bot. As you can see in the bot flow, in the image response there’s an option to upload the image. Let me know if this solution doesn’t work for you.

1 Like

Thanks for the reply @Pratik . I would like to load an image or video from a url too.
How to fetch a image/ Video from url ?

Also uploading media is not working at my end. It keeps showing a loading icon for like 5 mins for a 100kb image when i upload and it doesnt stop.

1 Like

Got it, I checked with our team.
It’s possible to fetch media from URL. However, the video needs to be in MP4 format hence fetching video from YouTube didn’t work. I’d recommend uploading a video on a server or CDN if you want to fetch a video from a URL.
I’ve also informed our team about the issue with media upload, we will fix that ASAP.
Thanks!

Thanks @Pratik .
I tried the method you had sugggested where i can fetch from server and it still doesn’t work. Tried an mp4 video with the this url : https://commondatastorage.googleapis.com/gtv-videos-bucket/sample/ElephantsDream.mp4
image

Bot showed a blank video only

I’m not sure but probably this issue might be also related to the variable issue which i had just posted :Problem with variables because the link may not be getting saved to the variable .

Please let me know how to overcome fetch from URL issue . Also please mention what the image formats supported to fetch from a URL

1 Like

We’re in the process to migrate all active users to our official platform (cloud.yellow.ai); where you can continue your bot-building without any issue.

Please share relevant information using this form: https://forms.gle/CSa6bzM99UxDNbxd7

1 Like

Thanks @Pratik , Tried visiting the form you had shared. It shows “You need permission” and file unavailable error .

1 Like

Can you please try again? I’ve removed the restriction now.

1 Like

Thanks @Pratik . Form is opening now.Filled and submitted. Thanks for the quick response

1 Like

Hi @Pratik
Fetching video from URL is working :grinning:

But Still having facing issue with fetching image from URL. It doesnt show image when i try to fetch from url . I tried to fetch a sample image from this URL https://random.dog/OhkEvLi.jpg and it didnt show anything in the bot.
Please let me know what to do to fetch images from URL .
Thanks

1 Like

Unfortunately, fetching from images is not available yet. You can still upload an image from your local machine.

1 Like

Thanks for the info and suggestion @Pratik
Update: Uploading image is working in cloud.yellow.ai

1 Like

Hi! How did you get the url video to work? Mine is still not working.
@Pratik

Hi @manasvi_logani … You can store the video url of mp4 format in a variable and use it in the video message . Fetching from youtube doesn’t work . So you need to upload the video to some server or CDN and use that url . And thats how it works for me.
Example url : https://commondatastorage.googleapis.com/gtv-videos-bucket/sample/ElephantsDream.mp4
Ref : Facing issues with image and video message - #4 by Pratik

2 Likes

Thank you @Rajasekar for helping fellow community member.

1 Like