Next step in the journey is not triggering

Hi,

Please see the flow here -

Please see the logs below:

4 minutes ago [9464343977691082761093289667_0Kik9Ku0Aci2NpfqrF91h][debug] Triggering Intent [virtualguidewith-3-options]
4 minutes ago [9464343977691082761093289667_0Kik9Ku0Aci2NpfqrF91h][debug] Switching to Journey [virtualguidewith-3-options]
4 minutes ago [9464343977691082761093289667_0Kik9Ku0Aci2NpfqrF91h][info] Language in memory : en
4 minutes ago [9464343977691082761093289667_0Kik9Ku0Aci2NpfqrF91h][debug] Executing Function - utilUserDetails
4 minutes ago [9464343977691082761093289667_0Kik9Ku0Aci2NpfqrF91h][info] Function Type V1
4 minutes ago [9464343977691082761093289667_0Kik9Ku0Aci2NpfqrF91h][debug] Fetching Journey Details for [VirtualGuideWith3Options]
4 minutes ago [9464343977691082761093289667_0Kik9Ku0Aci2NpfqrF91h][debug] Executing Init Function [virtualGuideInit]
4 minutes ago [9464343977691082761093289667_0Kik9Ku0Aci2NpfqrF91h][debug] Executing Function - virtualGuideInit
4 minutes ago [9464343977691082761093289667_0Kik9Ku0Aci2NpfqrF91h][info] Function Type V1
4 minutes ago [9464343977691082761093289667_0Kik9Ku0Aci2NpfqrF91h][info] :: virtualGuideInit ::
4 minutes ago [9464343977691082761093289667_0Kik9Ku0Aci2NpfqrF91h][debug] Finding Next Step to Execute
4 minutes ago [9464343977691082761093289667_0Kik9Ku0Aci2NpfqrF91h][debug] Executing Step[showoptions]
4 minutes ago [9464343977691082761093289667_0Kik9Ku0Aci2NpfqrF91h][debug] Executing prompts V1 for step [showoptions] journey [virtualguidewith-3-options]
4 minutes ago [9464343977691082761093289667_0Kik9Ku0Aci2NpfqrF91h][debug] Executing Response 1 of 1
4 minutes ago [9464343977691082761093289667_0Kik9Ku0Aci2NpfqrF91h][debug] Executing Message Type [func]
4 minutes ago {}
4 minutes ago [9464343977691082761093289667_0Kik9Ku0Aci2NpfqrF91h][info] Finished Executution for Async sources
3 minutes ago ------- ------- ------- ------- ------- -------
3 minutes ago [9464343977691082761093289667_6659sHSDQWIfKdbhJ5t8o][info] {
3 minutes ago “message”: “3”,
3 minutes ago “medium”: “message”
3 minutes ago } : received request in executor receive
3 minutes ago firsttimeusernotyellowmessenger -x1613400943626- 9464343977691082761093289667
3 minutes ago [9464343977691082761093289667_6659sHSDQWIfKdbhJ5t8o][info] sending response back for Async sources
3 minutes ago [9464343977691082761093289667_6659sHSDQWIfKdbhJ5t8o][debug] Executing Function - config
3 minutes ago [9464343977691082761093289667_6659sHSDQWIfKdbhJ5t8o][info] Function Type V1
3 minutes ago [9464343977691082761093289667_6659sHSDQWIfKdbhJ5t8o][debug] Executing Function - globals
3 minutes ago [9464343977691082761093289667_6659sHSDQWIfKdbhJ5t8o][info] Function Type V1
3 minutes ago [9464343977691082761093289667_6659sHSDQWIfKdbhJ5t8o][debug] Executing Function - stopwords
3 minutes ago [9464343977691082761093289667_6659sHSDQWIfKdbhJ5t8o][info] Function Type V1
3 minutes ago [9464343977691082761093289667_6659sHSDQWIfKdbhJ5t8o][info] app.context for my log : {}
3 minutes ago [9464343977691082761093289667_6659sHSDQWIfKdbhJ5t8o][info] app.context for my log :
3 minutes ago [9464343977691082761093289667_6659sHSDQWIfKdbhJ5t8o][info] Language in memory : en
3 minutes ago [9464343977691082761093289667_6659sHSDQWIfKdbhJ5t8o][debug] Executing Function - utilUserDetails
3 minutes ago [9464343977691082761093289667_6659sHSDQWIfKdbhJ5t8o][info] Function Type V1

Flow goes till show options and then reverts to main, without calling validator and/or handleVirtualGuideOptions.I am not sure what to do here.Pls guide.

thanks.

1 Like

Hello @Jaya_Banbah,
Can you please share the bot access with me at pratik@yellowmessenger.com?

Hello Pratik,

Given the admin access for bot.Thanks for looking into it.

1 Like

Hello,

Just wanted to mention here - when I restarted container, I noticed this error in log

[ DRUID_METRICS_INFO ] Elastic search url : [“http://@es-master-0:9200”,“http://@es-master-1:9200”,“http://es-master-2:9200”]
2 minutes ago [ DRUID_METRICS_INFO ] Data service url : http://data-service.services:3000
2 minutes ago {“f_s”:“x1613400943626”,“hostName”:“x1613400943626-cbf587f69-6sh8p”,“namespace”:“services”,“level”:“error”,“message”:"Error in parsing config file :: ",“timestamp”:“2021-06-04T08:50:50.410Z”,“f_t”:“2021-06-04T08:50:50.410Z”}
2 minutes ago config.urls.SUBSCRIPTION_SERVICE :: http://subscription-service.services:3000
2 minutes ago Listening on port 8888

Also, I have written the following in main funciton and it is coming up empty in logs:
app.log(app.context, “app.context for my log”);
app.log(app.context.steps, “app.context.steps for my log”);
app.log(app.context.data, “app.context.data for my log”);

1 Like

Hi @Jaya_Banbah

When you gave an input, we found that there was no app.start() in main function.

We have added that in main and its needed for the bot to start.

And regarding the error in restart container, its not an error,

It’s just showing that the container is being started again along with the port number

Please avoid app.context in main since, it should not be used in main

1 Like

Noted @Gowtham_Kishore.
Thank you for the help and explanation!

1 Like