YM Academy Day 3 QnA

Hello Folks,

Thank you for joining us for the Yellow Messenger Academy. If you’ve got any questions from day 3 session , you can drop your question in the comments below. :wink:

Slides: https://drive.google.com/file/d/1ks3YlGF-35kFnFMt_JlOPRH3z2t96WjX/view?usp=sharing

1 Like

Hi, the ppt/ pdf isnt available under the video yday! could you share it here for ready reference?

1 Like

Sure!

1 Like

Hello,

Here are some roadblocks I faced today.

  1. The bot direct link is not working.
  2. I tried importing a youtube API. I repeatedly got an error for missing OAuth and a valid access token whereas I had one. Should I remove OAuth before getting the cURL or GET apis?
  3. I tried to include a video. I added only mp4 URL, yet it threw an error for entering a valid mp4 URL. Could you explain what is this mp4 URL? is it a URL with .mp4 extension or a URL of an mp4 file hosted on platforms like vimeo, youtube etc.

Thank you.

1 Like

Hello Srinath,
Thank you for asking your queries here on the community.

  1. Can you please share the bot direct link here?
  2. If you can share more information on which YouTube API you’re using we can surely help you with the authentication part.
  3. Where you want to add a video?
    Thank you!

Hi, is it ok if I email the details? Can I have your email id?

1 Like

Sure, you can share more details at pratik@yellowmessenger.com

1 Like

Thank you, I have sent the email. Please help with the queries at the earliest.

1 Like

@Pratik The data type of a field in our database is of list type and yet it gets stored as a string when uploaded via a CSV file. The validation for an invalid array type does work when a record is added manually through UI.

Please suggest a possible solution!

Screenshot from 2020-09-23 17-26-00
Caption1: list field acts as a string one and shows up in db query results as a string (the field value whose record came from csv)

Screenshot from 2020-09-23 17-26-34
Caption2: list field behaves normally and is validated as a list (the field whose record was added via UI)

1 Like

Shubham, for a list you will have to add it as an array not as comma separated strings.

Would you mind looking at my doubt again? Sorry, this is not what I meant!

1 Like

Not an issue, we can discuss in detail during office hours call.

@Pratik Please help us out How do we fetch the data from our database and print it in the chat?

1 Like

Please use the app.dataStore.search for searching through the database and then you can show the results using appropriate response type.

@Original_Siddharth we tried that but search is giving all the details in the log but we weren’t able to print the required data into the chat. Can you please help us out with the code for function for printing the data into the chat.

2 Likes