Auto detect language is not working

We enabled auto-detect language detection, but it is not working. Language is also added to the bot.

Hi @Abhijeet_Kumar , I can see from the screenshot that you have initiated the conversation in english and in middle of the flow you are trying to change the language ? Correct me if im wrong

Yes, It should change the language

I dont think it functions in that manner. Since English language is already detected at the start of the flow. Bot will respond in english unless you change the language using a language node.

You can also refer to this document - Tools and settings |

1 Like

I understand what you’re saying, Harshin. We tried a different bot yesterday, and for a few moments it appeared that the bot was responding to the user’s language, but then it stopped. Could you point us in the right direction, please? Clients want to see this feature because they have an event on January 5.

HI @Abhijeet_Kumar,

Expected Outcome Auto Detect -

  1. Enable Auto Detect in the tools section.
    2.Consider , the bot is configured with two languages. Lets Say English and Hindi.
  2. You type Namste in hindi in the bot. The Bot will converse with you in that language unless you use a language node to change the language.

In your case you have mentioned language has changed in between. Did it change after encountering a language node or it changes suddenly in the flow ?

If it has changed suddenly in the flow, pls raise a ticket for the same.