Does "Hide input" also hide home button?

I am trying to hide input but it also hides the home button. I want just the text input area hid and show the home button. How can this be done?

Hey @Vamshika_Boinapally,

We are currently working on “not” hiding the home button when the “Hide Input” option is selected in

In the meantime, can you share your bot IDs so we can enable this behavior from our end?

And also, enable the toggle for the “Hide Home Button” in the Quick Reply node.

1 Like

“Hide input” hides input bar including home, and attachment buttons. This is used when you expect a user to select an option from quick reply, carousel, or any other component, and block them from sending a text input/upload image.

“Hide home button” only hides home button blocking users from going to home/main menu.
Users will still be able to provide text inputs.

1 Like

Yes, I am looking for a scenario when from the option user selects and done with the flow. disable text input but able to show home button so that they can get the menu again. Because enabling input at this stage we do not have a flow for it and shows a fallback message.
Bot Id dev: x1641550603986
Bot Id Live: x1641548239277

@Adithya_N_R Hello Adithya did u get a chance to look at my rely with bot ids?

Yes, @Vamshika_Boinapally

We will enable this behavior by the end of the day today. Will keep you posted here.

@Vamshika_Boinapally We have enabled this behavior for both bots.

1 Like

You can now select the “Hide home button” option in the quick reply node settings.


1 Like

It works, thank you.
One more question so in the studio where we see the preview of bot, it still has the old chat displayed when home and input text ws disabled. It doesnt go away. Have to pop the chat to another window to test. Is there any way that can be reset or cleared??

Could you share a screen recording so I can get more context about this?

So I am using the message text node. I do not see home button toggle for it. I selected hide input and it doesn’t display home button or input now. Kind of struck now . Since no home button displayed. The same chat window remains

Understood. Will get this checked with our backend team.

As a temporary fix to move forward with your testing,

Can you try clearing cache/browser history and letting us know if that resets your bot back to the welcome message.

If so, just to proceed with your testing, by enabling input for text nodes while I raise the issue by re-creating it internally.

And also want to check is the fix not for the bot as a whole. was it for just one node. Because I Was using carousel in another flow(ISO query) and it hid home button there. Can something be done at bot level?

@Adithya_N_R any update on this? did your team get to look into this?

Hi @Vamshika_Boinapally ,

I’ve raised this internally, can you raise a support ticket by writing to and link this conversation in your email.

That email chain can be used for all support needed for bugs/inconsistencies you’re facing

additionally, please provide access to and

Created the case 00039344 and gave access to the above 2 emails. Please check

Sure, I’ve followed up with some more details the team will need for this.

Let’s resume the rest of this debugging conversation over the support case.
Closing this thread here