Live agent translation facing issue - Inbox

We have enabled auto-translation. When the agent translates from English to Spanish, everything runs smoothly, but when the user responds in Spanish, nothing translates back to English. even though it’s showing a different text.

Hey @Abhijeet_Kumar Can you help us understand this better? Can you post screenshots of instances where end-user messages are not getting translated? Also, what do you mean by “it’s showing a different text”?

From the screenshots, I could see that Abhijeet’s message “Understand” has been translated from Spanish to the agent’s default language which is English here. You can click on Show original to see the actual message sent by the end user, if that helps.

Hi @Sandeep_Rajaram, I am also facing a similar issue with Live Translate.

We have a multilingual bot with live chat auto translation enabled.


  • User interacts with the bot in the French language
  • User issue requires human intervention
  • User connects with the live agent
  • User enters the query in the French language
  • Agent is English speaking agent
  • Agent is receiving the message in the French language; It should have come in the English language to the agent
  • Agent replies back in English
  • User is receiving the messages in the French language

Below are the screenshots for your reference.


Hey @RavinderMalhotra , Thanks for the detailed explanation.

Can you confirm if the default language of the agent is set as English in Inbox → Settings → Team → Agents → Click Edit on a particular agent → Default Language?

1 Like

Thanks, @Sandeep_Rajaram. The language setting was misconfigured. I updated the settings and it’s working now.

1 Like

Thank you for making this very descriptive @RavinderMalhotra :smiley: