Inbox inactivity trigger issue

We have setup inbox to mark tickets as inactive if agent does not respond for 3 mins, and close inactive tickets after 4 minutes.

Now if an agent says for example “hi” in the portal, the ticket is getting closed after the given time if he is inactive.

However, if the ticket is assigned to the agent and the agent does not respond (i.e. send the first message), the ticket is marked inactive, but it is not getting automatically closed.

Hey @Shraeyas , Auto closing of chats only works on customer inactivity [where the last message is from the agent and the customer did not reply back]

We do not recommend auto-closing chats due to agents being inactive as it would lead to a bad experience for the customer.

But if your expectation is still to auto-close chats due to agent inactivity, you will have to use the ticket close API in a journey with agent-inactivity as its event trigger. Hope this helps

1 Like

Hey @Sandeep_Rajaram Thanks for your response.

But we do have settings that says that if the agent is inactive for certain mins, mark the ticket as inactive and then later to close it. What does that setting do then?
image

@Dimple_Mehta the first two options trigger the inactivity events at the defined time limits so that you can capture them and send any custom message that you want.

The third option is the one that is responsible for the auto-closing chat tickets. This works only on customer inactivity conditions and not on agents.

is this ticket-close API public to perform the above mentioned on agent-inactivty event?

Understood, @Sandeep_Rajaram
Do you think we can rename the last setting then? Because it’s a little misleading and gives the impression that agent inactivity is also considered.

Sure @Dimple_Mehta . Thanks for the feedback! I will let our team know about this and we will look to improve the copy

1 Like

@gautham @Shraeyas You can use the API node to call this in the journey and close the chat tickets;

curl --location -g --request POST ‘https://cloud.yellow.ai/tickets/resolve?bot={{botId}}’
–header ‘x-api-key: {{x-api-key}}’
–header ‘Content-Type: application/json’
–data-raw ‘{
“ticketId”: “100350”
}’

Pls pass in the relevant bot id, ticket id and x-api-key parameters

1 Like